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In This Chapter
This chapter helps you learn how to use User Interface 1.0 with Benefactor or 
Colleague. It includes instructions for accomplishing various tasks, such as 
accessing a form, saving your work, and using online Help. It also provides 
guidance on using current documentation.

User Interface 1.0 is the third generation of the enhanced GUI. Features of 
User Interface 1.0 include:
■ Tabbed multiple forms managed within the application workspace
■ “Save All” and “Cancel All” functions
■ A Windows Explorer-style tree structure for process menus
■ A “Favorites” feature enabling quick access to commonly used processes
■ An address bar for launching specific processes
■ A Detail button next to every field that allows detail
■ A drop-down box next to every field that has validation codes
■ A calendar button next to every date field
■ A calculator button next to every numeric field
■ Support for proportional fonts
■ A GUI report browser and navigation buttons
■ Ability to store options for multiple users on a single client
■ Compatibility with Envision 4.6.1 and above
■ Compatibility with all supported operating systems
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Logging In
When you install User Interface 1.0 on your PC, icons are created on your 
desktop and in the Datatel group under Programs in your Windows Start 
menu.

Procedure for Logging In

Complete the following steps to log into a Datatel product:

Step 1. To display the Login dialog box, perform one of the following procedures:

■ Double-click the desktop icon , or 
■ Select Datatel from the Datatel menu under Programs in the Windows Start 

menu.

The Login dialog box is displayed, as shown in Figure 3-1.

Figure 3-1: User Interface 1.0 Login Dialog Box

Step 2. Enter your user ID and password and click OK. A dialog box appears, 
informing you that User Interface 1.0 is loading the application files. When 
the files are loaded, the application workspace appears, as shown in 
Figure 3-2.

ALERT!  If you also use FrontView, be sure to close it before 
starting User Interface 1.0. Running User Interface 1.0 and 
FrontView simultaneously will cause a script error.

Pull down to 
display 

accounts 
available
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Logging In
Figure 3-2: Application Workspace

Tree Menu Panel
Contents of the Folder That Is 
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System Menu Bar
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Note:  The Save All  and Cancel All  buttons and the 
corresponding File drop-down menu options enable you to save or 
cancel all of your changes simultaneously to every screen that is 
currently open.
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Step 3. If necessary, select the application with which you wish to work from the 
Apps menu at the top of the application workspace. The left panel of the 
application workspace displays the folders and processes available for the 
selected application in expandable tree format.

Click the Plus sign  next to any folder icon in the left panel to expand the 
folder. When a folder is expanded, you can click the Minus sign  next to its 
icon to collapse it.

Double-click a folder icon in either panel to expand the folder. Double-click a 
form icon in either panel to open the form.

When a form is open, it is displayed in the right panel. When no form is open, 
the right panel displays the contents of the folder that is currently selected.

Note:  Using Colleague 17.0 you can choose to have the left panel of 
the application workspace remain visible (default condition), or to hide 
it in order to allocate more space to the form.
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The Application Workspace
The Application Workspace
The application workspace, shown in Figure 3-2 on page 3-3, is the container 
for all the processes you use while working with Benefactor or Colleague.

Title Bar

The title bar, shown in Figure 3-3, tells you which Colleague or Benefactor 
database you are accessing and which application you are currently running. 
The title bar is highlighted when the application workspace is the active 
window.

Figure 3-3: Title Bar

System Menu Box

Click the System menu box  to access the System menu options: Restore, 
Move, Size, Minimize, Maximize, or Close. Depending on the current state of 
the application workspace, some options may be disabled. To close the 
application workspace when no forms are open, you can double-click the 
system menu box. If any forms are open, a message indicates that you cannot 
close the control box when you are in a form.

Menu Bar

The menu bar, shown in Figure 3-4, enables you to:
■ Perform routine tasks, such as save your work or cut and paste items
■ Choose an application with which to work; for example, the Financial 

System or the Human Resources System
■ Choose a form in which to work
■ Define your preferences for how forms are displayed
■ Access online Help
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Figure 3-4: Menu Bar Detail

Toolbar

The toolbar, shown in Figure 3-5, provides easy access to common functions, 
such as saving your work, canceling changes, deleting records, and accessing 
online Help.

Figure 3-5: Toolbar Detail

Address Bar

The address bar, shown in Figure 3-6, enables you to access any form directly 
by entering its mnemonic, or by using the drop-down menu button  to 
select a previously used mnemonic. Press Enter or click the Go button 

 to display the selected form.

Save

Cancel

Save All
(Colleague 17.0 

only)
Cancel All

(Colleague 17.0 
only)

Record 
Delete

Exit Field Help

Save All
(Colleague 17.0 

only)

Note:  The Record Delete button  is used to delete an entire record, 
and only works for forms which have been defined to allow this option. 
When you click this button, you are prompted to confirm that you wish 
to delete the entire record.

The Save All  and Cancel All  buttons and the corresponding 
File drop-down menu options, available only with Colleague 17.0, 
enable you to save or cancel all of your changes simultaneously to 
every screen that is currently open.
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The Application Workspace
Figure 3-6: Address Bar Detail

System Menu Bar

The System menu bar, shown in Figure 3-7, enables you to minimize, 
maximize, or close the application workspace.

Figure 3-7: System Menu Bar Detail

When the application workspace is maximized, the Maximize button  is 
replaced by the Restore button  in the System Menu bar.

Minimize Maximize Close

Note:  You can also resize the application workspace by dragging its 
outer frame.
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What is a Form?
Most of your work in Benefactor or Colleague is done through forms. In 
documentation for earlier interfaces, what we refer to here as a “form” is often 
called a “screen.” They are the same thing; we have chosen to use the term 
“form,” however, to keep our terminology consistent with standard Windows 
usage, while referring to the application workspace or a resolution list as a 
“screen.” 

When you select a form in Colleague 17.0, it appears in the right panel of the 
application workspace, as shown in Figure 3-8, with its name and mnemonic 
displayed on a tab.

Figure 3-8: Sample Form in Application Workspace (Colleague 17.0)

Note:  The Save All  and Cancel All  buttons and the 
corresponding File drop-down menu options enable you to save or 
cancel all of your changes simultaneously to every screen that is 
currently open.

Note:  Depending on your font, resolution, and monitor size, scroll 
bars are available as needed to view forms that do not fit in the 
application workspace.
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What is a Form?
The details of the sample form are shown in Figure 3-9.

Figure 3-9: Sample Form Detail

Form Tab

The form tab displays the form mnemonic and the form name. When more 
than one form is open, the tab furthest to the right represents the active form.

Header
Block

Data
Area

Form Mnemonic Form Name

Note:  While a form is open in Colleague 17.0, you can allocate more 
viewing space to it by choosing Hide Tree Menu from the Edit menu. 
The left tree menu panel closes, and the form now occupies the entire 
application workspace. Choose Hide Tree Menu from the Edit menu 
again to toggle this option off and display the tree menu in the left 
panel.
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Header Block

The header block displays data that identifies the item with which you are 
working. For example, the header block in Figure 3-9 on page 3-9 displays a 
student’s name and ID.

Data Area

The contents of the data area differ depending on the form with which you are 
working. In general, the data area consists of various types of fields.

Fields

A field is any place on the form where data is displayed or where you enter 
data. In most cases, each field is accompanied by a field label indicating what 
kind of data belongs in the field.

What you are allowed to enter in a field may or may not be restricted by 
Benefactor or Colleague. For example, Benefactor and Colleague allow you 
to enter any combination of letters for a person’s name. On the other hand, in 
the Type field on the CORE System’s Address Maintenance (ADR) form, you 
can only enter one of the values from the list of valid address types, such as 
“Home,” “Business,” or “Local.” Fields such as this, where your entries are 
restricted, are referred to as “validated fields.”

Another unique kind of field is a detail field, which allows you to access 
another form from the form you are on. See “Detail Forms” beginning on 
page 3-15 for more on this topic.

Groups

A group is a set of related fields. Each field in a group can have multiple 
values. Furthermore, there are usually several fields in a group that are 
associated with each other in some way; these are often referred to as 
associated multivalues. Some sets of associated multivalues are presented as 

Note:  With fields that are code-driven, such as validated fields, you 
will notice that the code’s description disappears when you are 
entering data in the field. This is intentional. The code’s description 
returns as soon as you leave the field. See “Drop-Down Table Button” 
beginning on page 3-22 for information about selecting codes for 
validated fields.
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What is a Form?
rows and some are presented as columns; that is, some groups are row-
oriented and some are column-oriented. In either case, the intersection of a 
column and a row is referred to as an element.

The Line Items group shown on the Relation Information (REL) form in 
Figure 3-10 is a row-oriented group. You read each set of fields across a row.

Figure 3-10: Example of a Row-Oriented Group 

Field Text and Background Colors

You can choose Change Colors from the Options menu to set field text and 
background colors to fit your preferences (see “Colors” beginning on 
page 3-53). The Datatel defaults reflect field type, with a white background 
for editable fields and a gray background for non-editable fields, as follows:
■ Normal (editable): black text on white background
■ Inquiry (not editable): black text on gray background
■ Detail (editable): black text on white background
■ Inquiry/Detail (not editable): black text on gray background

Group

Row

Element

Panel
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Accessing a Form

From the Tree Menu

The graphical, tree-structured menus enable you to navigate through an 
application’s menus and submenus by pointing and clicking, while 
maintaining a comprehensive view of the entire menu. When you select an 
application, the application workspace menu form is displayed, as shown in 
Figure 3-2 on page 3-3. The left tree menu is the main navigational menu. The 
right menu displays the submenus and forms contained in the folder selected 
in the left menu.

Menus and submenus are represented by folder icons, while forms are 
represented by four different icons according to functionality, as shown in 
Figure 3-11.

Figure 3-11: Expanded Tree Menu
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Accessing a Form
■ Maintenance. Maintenance forms, represented by the Maintenance icon 

, allow you to enter and change data that is permanently recorded in 
your database; for example, a person’s name and address.

■ Processing. Processing forms, represented by the Processing icon , 
allow you to start a program that manipulates a record or group of records 
behind the scenes; for example, posting a group of transactions to the 
general ledger.

■ Inquiry. Inquiry forms, represented by the Inquiry icon , allow you to 
view information without changing it; for example, the history of a general 
ledger account. Strictly speaking, inquiry forms are forms that are designed 
to display information without allowing changes to that information. In 
contrast to an inquiry form designed as such, you may also access a 
maintenance form in inquiry mode if your system administrator has given 
you read-only access to it. Although the effect for you is the same, a 
maintenance form viewed in inquiry mode is, nevertheless, different from a 
form designed specifically as an inquiry form.

■ Reporting. Reporting forms, represented by the Reporting icon , allow 
you to generate a particular report according to your specifications. For 
example, today you may wish to see a report on vouchers with a due date 
two weeks from now, and tomorrow you may decide you want to see the 
same report for vouchers with a due date four weeks from now.

Locating and Selecting Forms

You can locate and select forms in several ways:
■ Use the tree menu to navigate through the folders. Once you have selected 

the appropriate top-level folder, you can expand it to locate the desired 
form. To select a folder or form in a tree menu, double-click it.

■ Enter a form mnemonic in the address bar, shown in Figure 3-12, or use the 
drop-down list to select a previously used form mnemonic. Press Enter or 
click the Go button  to display the form. 

Note:  If your system administrator has given you read-only access to 
a maintenance form, you will be able to access it in inquiry mode only, 
even though it displays the Maintenance icon in the tree menu.

Note:  See “Browsing Reports” beginning on page 3-45 for information 
about the Report Browser.
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Figure 3-12: Address Bar

■ Use the Favorites drop-down menu to select a form that has been 
previously added to your list of favorites, as shown in Figure 3-13. See 
“Favorites” beginning on page 3-56 for information about creating a list of 
favorites.

Figure 3-13: List of Favorites

■ Click the File menu to display the mnemonics of the last ten forms you 
accessed, and select a form from the list.

■ Choose Run from the File menu or press Alt-F-R. The Envision Run 
dialog box appears, as shown in Figure 3-14. Enter the mnemonic of the 
form you want, click OK, and Benefactor or Colleague will display it.

Figure 3-14: Envision Run Dialog Box

Pull down to display
previously selected mnemonics
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Accessing a Form
Detail Forms

Some forms only give you limited or summary information about a certain 
item, but provide you with the capability of moving to another form. This 
form, which is known as a detail form, provides more complete information 
on that item. For example, as shown in Figure 3-15, the Student Profile 
(SPRO) form contains the Academic Program field. The Academic Program 
field only provides a code to indicate the program. To the right of the field is a 
Detail button , which allows you to detail to the Student Academic 
Program (SACP) form for more information about the academic program.
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Figure 3-15: Student Profile (SPRO) Form Detailed to Student Academic 
Program (SACP) Form
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Accessing a Form
When you click the Detail button to the right of the Academic Program field, 
the SACP form is displayed with its tab to the right of the SPRO form tab, as 
shown in Figure 3-15.

Although the usual workflow is to access a detail form from another form, 
some detail forms are also available from the menu tree. Others, even though 
they are not listed on a menu, may still be accessed directly (see “Accessing a 
Form” beginning on page 3-12 for more on this topic). Detail forms that can 
be accessed only via another form are referred to as detail-only forms.

So how do you know whether a detail form is available from the form you are 
working on and, if so, how do you access it? You will know a detail form is 
available for a field if there is a Detail button to the right of the field. Such 
fields are referred to as detail fields.

You can use one of the following two methods to access a detail form from a 
detail field:
■ Click the Detail button to the right of the field.
■ With the cursor in the detail field, choose Detail from the File menu.

Shortcuts

If you prefer to bypass the tree menus, you can use shortcuts to access forms 
that are otherwise available from a tree menu. You can also use these shortcuts 
to access detail forms, as long as they are not detail-only forms. See “Detail 
Forms” beginning on page 3-15 for more information about accessing detail 
forms.

Address Bar

To access a form from the address bar, enter its mnemonic in the text box, as 
shown in Figure 3-12 on page 3-14, and press Enter or click Go. The specified 
form is displayed.

Note:  The tab furthest to the right represents the active form. To 
ensure that each record is completed properly, only one form can be 
edited at a time. All forms below the current open form are inquiry only 
and do not allow input. Data on these forms is grayed out while another 
form is active.

Note:  If you try to access a detail-only form directly, a message is 
displayed telling you that you cannot do so.
Guide to User Interfaces, December 31, 2003 3-17
© 2003 Datatel, Inc.



User Interface 1.0: About User Interface 1.0
File Menu Drop-Down List

You can display any one of the last ten forms you have accessed previously by 
selecting it from the File menu as shown in Figure 3-16.

Figure 3-16: File Menu Showing Previously Selected Forms

Run Dialog Box

Complete the following steps to access a form directly, using the Run Dialog 
box:

Step 1. From the File menu, choose Run (or press Alt-F-R). The Run Dialog box is 
displayed, as shown in Figure 3-14 on page 3-14.

Step 2. Enter the desired mnemonic in the text box and click OK. The specified form 
is displayed.

Direct Access

If you have a form open, you can choose Direct Access from the File menu to 
save or cancel the current record and open a different form for the same key. 
For example, if you are working with a person in the Name and Address Entry 
(NAE) form and then use Direct Access to move to the Biographic 
Information (BIO) form, the NAE form is closed and the BIO form opens 
with the same person selected. When you finish from the second form, you 
are returned to the original form.
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Accessing a Form
Favorites

You can also create and organize a list of favorite forms to be accessed from 
the Favorites drop-down menu, as shown in Figure 3-13 on page 3-14. See 
“Favorites” beginning on page 3-56 for information about setting up 
Favorites.
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Additional Features of User Interface 1.0
User Interface 1.0 offers several additional features in the form of control 
buttons that assist you in viewing and editing data, as shown in Figure 3-17.

Figure 3-17: Additional Features

Detail Button

A Detail button  appears to the right of each Detail field and allows you to 
access the associated detail form. For more information, see “Detail Forms” 
beginning on page 3-15.

Window Operation Button

A Window Operation button  enables you to insert or delete a row of data. 
When you click the Window Operation button, the Select Window Operation 
dialog box is displayed, as shown in Figure 3-18.

Window
Operation

Button

Detail Button

Date/Calendar 
Button

Drop-Down
Table Button

Scroll
Buttons

Calculator 
Button
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Additional Features of User Interface 1.0
Figure 3-18: Select Window Operation Dialog Box

■ Click Insert to insert a new row above the current row.
■ Click Delete to delete the current row.
■ Click Cancel to leave the row unchanged and return to editing.

Scroll Buttons

Scroll buttons enable you to view multiple values. There are two different 
types of scroll buttons:

 Small buttons appear to the right of fields that display one value at a
time.

 Larger buttons appear to the right of fields that display two or more
values at a time.

Date/Calendar Button

A Date/Calendar button  appears to the right of each date field. Click the 
Date/Calendar button to display the calendar browser, as shown in 
Figure 3-19.
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Figure 3-19: Calendar Browser

Click the single arrows to scroll the calendar backwards  or forwards  
by month, or the double arrows to scroll backwards  or forwards  by 
year. Click the desired date in the body of the calendar to select it.

Calculator Button

A Calculator button  appears to the right of each numeric field. Click the 
Calculator button to display a calculator, as shown in Figure 3-20.

Figure 3-20: Calculator Feature

Drop-Down Table Button

A Drop-Down Table button  appears to the right of each field that has a 
predetermined set of valid entries. Click the Drop-Down Table button to 
display a validation code table, as shown in Figure 3-21.
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Additional Features of User Interface 1.0
Figure 3-21: Validation Code Table

Click on the appropriate code to select it.

Multiple User Profiles

User Interface 1.0 supports multiple user settings on one PC. If a PC is shared 
by more than one user, User Interface 1.0 maintains individual color settings, 
font sizes, and favorites menus for each user ID. See “Defining Your 
Preferences” beginning on page 3-52 for information on setting user 
preferences.

Note:  The Windows 95 and 98 operating systems place constraints 
on the number of controls that can be displayed on a form. If 
necessary, User Interface 1.0 omits some control buttons from the 
display and prompts you to contact the Solution Center. This may 
occur with custom forms that contain a large number of controls.
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Finding a Record
Now that you know how to access a form, you need to know how to access the 
records you want to work with on that form. For example, if you want to 
change a person’s address, you must tell Benefactor or Colleague which 
person you want to see.

You specify which record you wish to work with by responding to the 
LookUp prompt that is displayed after you access a form. LookUp prompts 
are displayed in a dialog box similar to that shown in Figure 3-22.

Figure 3-22: LookUp Prompt

Notice that the LookUp prompt is labeled, in this case, “Person LookUp.” 
LookUps that pertain to people or organizations are referred to as person- and 
organization-related LookUps. Person LookUp, Student LookUp, Applicant 
LookUp, and Vendor LookUp are a few of the person- and organization-
related LookUps you will find in Benefactor or Colleague.

Some fields within forms are validated against other files. LookUp is used in 
such fields to help you locate valid codes or items that you wish to associate 
with the main record on which you are working. When you are in a field that 
is validated against another file, you will see a LookUp indicator in the lower 
left corner of the form, as shown in Figure 3-23.
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Finding a Record
Figure 3-23: Example LookUp Indicator for a Field That Is Validated Against 
Another File

When you are using LookUp in a field that is not wide enough to display all 
the characters you want to enter, you can choose Wide Edit from the Edit 
drop-down menu. A LookUp dialog box is displayed, as shown in 
Figure 3-24.

Figure 3-24: Example of Using Wide Edit for LookUp

Field Validated 
Against Another

File

LookUp Indicator

Note:  You can use Wide Edit in any field, whether it involves LookUp 
or not, to provide additional display and editing space. The defined 
field size is the limiting factor for the number of characters you can 
enter.
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Basic LookUp

If you know the ID, or key, for the record you need, you can simply enter it at 
the LookUp prompt. For example, James Smithfield’s ID number is 1150. As 
shown in Figure 3-25, if you enter 1150 at the Person LookUp prompt for the 
Name and Address Maintenance (NAE) form, information about Mr. 
Smithfield is displayed.

Figure 3-25: Basic LookUp

Beyond Basic LookUp

When you do not know the record ID or if you are adding a new record, 
LookUp provides a number of options that help you find the record or find out 
if one already exists using the information you do have. For example, if you 
do not know Mr. Smithfield’s ID number, you can enter his last name at the 
Person LookUp prompt. As shown in Figure 3-26, if you enter “smithf” at the 
Person LookUp prompt for the Name and Address Maintenance form, a list of 
all the people in your database whose names begin with “Smithf” is displayed 
on a resolution screen.1 You can then select James Smithfield from this list.

1. A resolution screen is a screen that displays a list of all records that match the 
search criteria you entered at the LookUp prompt.
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Finding a Record
Figure 3-26: Resolution Screen

There are a number of LookUp options available to help you with almost all 
types of LookUp. In addition to these standard options, most types of LookUp 
provide special shortcuts to help you find what you are looking for. The 
standard LookUp options are presented in “Standard LookUp Options” below. 
The special shortcuts for specific types of LookUp are presented in your 
Benefactor or Colleague module documentation.

Person- and organization-related LookUps are a special case, and are found 
throughout Benefactor and Colleague. See “Special Options for Person- and 
Organization-Related LookUps” beginning on page 3-31 for more 
information.

Standard LookUp Options

As noted above, there are several LookUp options that work with most types 
of LookUp. LookUp options that do not work for person- and organization-
related LookUps are noted in the “Hints” column in Table 3-1.
Guide to User Interfaces, December 31, 2003 3-27
© 2003 Datatel, Inc.



User Interface 1.0: About User Interface 1.0
When you want to see... Enter this at the LookUp 
prompt Hints

The last record you displayed 
during this login session of the 
type that is appropriate for this 
form

An “at” sign (@)

For example, both the Name and 
Address Maintenance (NAE) form 
and the Address Maintenance 
(ADR) form are people-related 
forms. If you displayed Fred Smith’s 
record on the NAE form and then 
you accessed the ADR form, you 
could retrieve Mr. Smith’s record on 
the ADR form simply by entering @.

The “at” (@) sign allows you to 
retrieve the last form-appropriate 
record you displayed in most, but not 
all, cases.

A list of all records appropriate 
for this form

An ellipsis (...) The ellipsis is not supported for 
Person and Org LookUp.

A list of fields in the file that 
contains the record you are 
seeking

A semicolon (;) You can use the field names to 
construct a query statement to look 
for the record you are seeking.

All records in which a specific 
field contains a value (that is, 
the field is not blank)

;fieldname

For example, on the Approvals 
Needed (APRN) form in the 
Financial System’s Accounts 
Payable module, if you wanted to 
see a list of approval records for 
individuals who are limited in the 
purchase order amount they may 
approve, you would enter the 
following:

;apprv.po.max.amt

All records in which a specific 
field’s value matches a 
particular string

;fieldname string

For example, on the Approvals 
Needed (APRN) form in the 
Financial System’s Accounts 
Payable module, if you wanted to 
see a list of approval records for 
individuals who can approve up to 
$10,000 on a purchase order, you 
would enter the following:

;apprv.po.max.amt 
10000

Text values, such as “Hall,” are often 
case-sensitive.

With the exception of a person’s 
name, multiword values must be 
enclosed within double quotes.

You can also look for multiple values 
at one time. For example, if you 
wanted to see a list of approval 
records for individuals who can 
approve up to $10,000 or up to 
$15,000 on a purchase order, you 
would enter the following:

;apprv.po.max.amt 
10000 15000

Table 3-1:  Standard LookUp Options 
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All records in which a specific 
field’s value begins with a 
particular string

;field string...

For example, on the Job Skill 
Definition (JSKL) form in the Human 
Resources System’s Personnel 
module, if you wanted to see a list of 
all job skill definitions whose 
descriptions began with the word 
“Typing” or “Type,” you would enter 
the following:

;jsk.desc Typ...

Use this option when you are not 
sure how the item you are looking 
for is spelled or worded but you 
know how it starts.

Remember that text values, such as 
“Typ,” are often case-sensitive.

All records in which a specific 
field’s value contains a 
particular string

;fieldname 
...string...

For example, on the Job Skill 
Definition (JSKL) form in the Human 
Resources System’s Personnel 
module, if you wanted to see a list of 
all job skill definitions whose 
descriptions had the word “Typing” 
or “Type” in them, you would enter 
the following:

;jsk.desc ...Typ...

Use this option when you are not 
sure how the item you are looking 
for is spelled or worded but you 
know that it contains a certain word 
or part of a word.

Remember that text values, such as 
“Typ,” are often case-sensitive.

All records in which a specific 
field’s value ends with a 
particular string

;fieldname
...string

For example, on the Job Skill 
Definition (JSKL) form in the Human 
Resources System’s Personnel 
module, if you wanted to see a list of 
all job skill definitions whose 
descriptions ended with the word 
“Wpm,” you would enter the 
following:

;jsk.desc ...Wpm

Use this option when you are not 
sure how the item you are looking 
for is spelled or worded but you are 
fairly certain about how it ends.

Remember that text values such as 
“Wpm,” are often case-sensitive.

When you want to see... Enter this at the LookUp 
prompt Hints

Table 3-1:  Standard LookUp Options (cont’d)
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All records in which a specific 
file’s value contains several 
strings

;fieldname 
...string1...string2

or any combination of strings and 
ellipses to achieve the desired 
result.

For example, on the Job Skill 
Definition (JSKL) form in the Human 
Resources System’s Personnel 
module, if you wanted to see a list of 
all job skill definitions whose 
descriptions contained the word 
“Typing” followed by the number 
“80,” you could enter the following:

;jsk.desc 
...Typing...80...

Use this option when you are not 
sure how the item you are looking 
for is spelled or worded but you 
know that it contains certain words 
or parts of words. You can use any 
combination of ellipses and strings 
to find what you are looking for.

Remember that text values, such as 
“Typing,” are often case-sensitive.

All records in which a specific 
field’s value is related in some 
way to a particular string (for 
example, is greater than or 
less than something)

;fieldname operator 
string

The following are valid operators:

• = or EQ (equal)

• <> or NE (not equal)

• > or GT (greater than)

• >= or GE (greater than or 
equal to)

• < or LT (less than)

• <= or LE (less than or equal to)

• UNLIKE (use this operator only 
when you use an ellipsis in 
specifying a data value)

For example, on the Approvals 
Needed (APRN) form in the 
Financial System’s Accounts 
Payable module, if you wanted to 
see a list of approval records that 
were added on or after January 1, 
1999, you would enter the following:

;approvals.add.date 
ge 010199

When you want to see... Enter this at the LookUp 
prompt Hints

Table 3-1:  Standard LookUp Options (cont’d)
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You can also string together several LookUp criteria. For example, on the 
Campaign Planning (CMP) form in the Alumni and Development System’s 
Campaign Management module, if you wanted to find the campaigns that 
start in March and that have a campaign goal of $10,000 or more, you would 
enter the following:
;activity.donation.goal ge 10000 ;activity.start.month 3

Special Options for Person- and Organization-Related 
LookUps

The information most commonly used to look for a person or organization is 
the name of the person or organization. Table 3-2 presents the LookUp 
options you can use with person- and organization-related LookUps.
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When you want to... Enter this at the LookUp 
prompt Hints

Search using a person’s name lastname (at least the first two 
letters)

lastname, firstname

lastname, firstname 
middlename

lastname, firstname 
middleinitial

firstname lastname

firstname middlename 
lastname

firstname middleinitial 
lastname

For example, to look for or add a 
new person with the name of 
Robert Taylor Smith, you could 
enter any of the following:

sm

smi

smith

smith, robert

smith, robert

smith, robert taylor

smith, robert t

robert smith

robert taylor smith

robert t smith

You must enter an underscore (_) 
between the parts of multiword 
names. For example,

van_dyke, jo_anne

You can also enter only the 
beginning of the first and last 
names (at least the first two letters 
of the last name). For example,

sm, ro

ro sm

LookUp finds any record with a 
primary, birth, former, or other 
name like the name entered.

If you choose to add a new record 
after looking someone up by his or 
her name in this manner, then 
regardless of how you entered the 
name, each word in the name is 
transformed into lowercase and 
then capitalized appropriately; for 
example, if you enter van_dyke, 
jo_anne, you would get “Jo Anne 
Van Dyke.”

Table 3-2:  Person- and Organization-Related LookUp Options 
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Limit a name search Enter any of the following after the 
name:

;c city

;st state/province

;z zipcode/postalcode

;f country

;y class

;s source

;ps status

For example, if you wanted to find 
the Robert Smith whose preferred 
address is in Boston, you could 
enter the following:

robert smith ;c boston

You can string together more than 
one restriction for a search, as 
long as you separate each 
element of the search with a 
semicolon.

For example, if you wanted to find 
the Robert Smith whose preferred 
address is in Boston and who is 
associated with the reunion class 
of 1954, you could enter the 
following:

robert smith ;c boston 
;y 1954

Preserve capitalization as entered 
when adding a new person

=name

For example, if you enter 
=JoAnne T di_Marco, then 
the name displays exactly as you 
entered it. If you entered only 
joanne t di_marco, then 
the name would have been 
capitalized as follows: Joanne T. Di 
Marco.

If the name is not preceded by an 
equal sign, then regardless of how 
you entered the name, each word 
in the name is transformed into 
lowercase and then capitalized 
appropriately.

Who has a particular Social 
Security or Social Insurance 
number

;ss SSN/SIN

For example, Mary Browning’s 
Social Security number is 264-99-
8765. If she gave you her Social 
Security number instead of her ID 
number, you would enter the 
following to look her up:

;ss 264998765

You may enter hyphens, but they 
are not necessary.

When you want to... Enter this at the LookUp 
prompt Hints

Table 3-2:  Person- and Organization-Related LookUp Options (cont’d)
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Search using an organization’s 
name

orgname

For example, to look for or add a 
new organization with the name of 
Universal Office Supplies, you 
could enter any of the following:

universal

office

supplies

universal office

universal office supplies

If you choose to add a new record 
after looking up an organization by 
its name, then regardless of how 
you entered the name, each word 
in the name is transformed into 
lowercase and then capitalized 
appropriately; for example, if you 
entered universal office supplies, 
then you would get “Universal 
Office Supplies.”

Preserve capitalization as entered 
when adding a new organization

=orgname

For example, if you enter =e e 
cummings Institute, then 
the name will be displayed exactly 
as you entered it. If you had 
entered only e e cummings 
Institute, then the name would 
have been capitalized as follows:

E E Cummings Institute

If the name is not preceded by an 
equal sign, then regardless of how 
you entered the name, each word 
in the name is transformed into 
lowercase and then capitalized 
appropriately.

Limit a name search Enter any of the following after the 
name:

;c city

;st state/province

;z zipcode/postalcode

;f country

For example, if you wanted to find 
the Universal Office Supplies in 
Dayton, you could enter the 
following:

universal ;c dayton

When you want to... Enter this at the LookUp 
prompt Hints

Table 3-2:  Person- and Organization-Related LookUp Options (cont’d)
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Working with a Group of Records
When you want to review or work with a set of records on a given form, you 
can select a group of records directly from a resolution screen, as shown in 
Figure 3-27.

Figure 3-27: Resolution Screen

You can select a group of records in either of two ways
■ Click the box to the left of each desired record to highlight it.
■ Use the keyboard to enter F(lag) in the controller lookup resolution box, 

followed by each record number you want to select. Each selected record is 
highlighted as soon as you press Enter.

When you have selected all the records you want, click the Save button  at 
the bottom of the resolution screen, click the Save button on the User 
Interface 1.0 toolbar, choose Save from the File menu, or type Alt-F-S. 
User Interface 1.0 displays the first of your selected records on the form. You 
can make changes, save, and exit. You can then display the next record or 
jump to another record in the group. User Interface 1.0 shows which record is 
currently displayed at the bottom of the form, as shown in Figure 3-28.
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Figure 3-28: Displaying One Record of a Group

Cycling Through A Selected Group of Records

To cycle through the records in a group, save or cancel changes to the 
currently displayed record.

Saving a Record and Displaying Another Record

Perform the following steps to save the current record and display another 
record in the selected group:

Step 1. Click the Save button, or press Alt-F-S. An alert box prompts you to 
update, cancel or return to editing, as shown in Figure 3-29.
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Figure 3-29: Alert Dialog Box: Update, Cancel, or Return

Step 2. Click the Update button, press Enter, or type U to choose Update. An alert box 
is displayed, as shown in Figure 3-30.

Figure 3-30: Alert Dialog Box: Discard, Previous, Next, or Jump

Step 3. Choose one of the following actions:
■ Click Previous or type P to move to the previous record in the list
■ Click Next or type N to move to the next record in the list
■ Click Jump or type J to select a specific record in the list

If you do not want to edit any more records in the list, click Discard, press 
Enter, or type D to discard the entire list.

Canceling Your Changes and Displaying Another Record

Perform the following steps to cancel your changes to the current record and 
display another record in the selected group:

Step 1. Click the Cancel button, or press Alt-F-C. An alert box prompts you to 
cancel or return to editing, as shown in Figure 3-31.
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Figure 3-31: Alert Dialog Box: Cancel or Return

Step 2. Click the Cancel button, press Enter, or type C to choose Cancel. An alert box 
is displayed, as shown in Figure 3-30 on page 3-37.

Step 3. Choose one of the following actions:
■ Click Previous or type P to move to the previous record in the list
■ Click Next or type N to move to the next record in the list
■ Click Jump or type J to select a specific record in the list

If you do not want to edit any more records in the list, click Discard, press 
Enter, or type D to discard the entire list.
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Running Batch and Report Processes
When you run batch and report processes, the Progress Bar Graph displays the 
progress of each process.

As each process is completed, a Finish prompt displays. You can click the 
Finish button to start and view the progress of the next process. Continue 
clicking Finish as each prompt appears.

If you wish to view all of the processes consecutively (without having to click 
Finish for each process), select the “Close automatically when complete” box.

There are four types of progress bar graphs.

Message Bar Graph

Displays on the messages of a process, without the progress bar.

Figure 3-35: Message Bar Graph
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Single-Process Bar Graph

Displays a single process in a bar graph.

Figure 3-36: Single-Process Bar Graph

Multiple-Process Bar Graph

Displays more than one process in multiple bar graphs.

Figure 3-37: Multiple-Process Bar Graph
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Terminal Window Bar Graph

Displays GEN and Painter processes. Your system administrator can 
optionally choose to display all of your bar graphs in a Terminal Window. By 
electing to use the Terminal Window Bar Graph, you no longer have the 
option to view the progress of each process.

Figure 3-38: Terminal Window Bar Graph
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Browsing Reports
The User Interface 1.0 Report Browser allows you to view reports easily in a 
Windows environment. During viewing, the browser imports the document 
one page at a time as requested, so that lengthy download times are avoided.

To use the Report Browser, perform the following steps:

Step 1. Select the desired report from the tree menu.

Step 2. Fill in the desired report parameters, as shown in Figure 3-39, and update.

.

Figure 3-39: Bank Deposit Report (BDEP) Form

Note:  Because the Report Browser brings the report to the client one 
page at a time, there is a delay of approximately a second between 
clicking a page selection button and displaying the page on the screen.
Guide to User Interfaces, December 31, 2003 3-45
© 2003 Datatel, Inc.



User Interface 1.0: About User Interface 1.0
Step 3. Update from the first screen and select H Hold/Browse File Output 
from the Output Device drop-down menu, as shown in Figure 3-40.

Figure 3-40: Output Device Drop-Down Menu

Step 4. Continue updating until the Progress Bar Graph is displayed. (See “Running 
Batch and Report Processes” on page 3-42.)

Step 5. When all records are processed, you are prompted to browse the HOLD files. 
The Report Browser is displayed. Figure 3-41 shows a typical report page in 
the Report Browser.
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Figure 3-41: Report Browser

Using the Report Browser Toolbar

Use the toolbar buttons, shown in Figure 3-42, to navigate through the report, 
print the report, or save a copy.

Figure 3-42: Report Browser Toolbar Detail

Title Bar Toolbar

Scroll bars

Import

Last Page

Print
Local

Page Up
Page Down

Current Page/
Total Pages

First Page

Print
Remote

Exit
Browser
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■ Click the Exit Browser button  to close the Report Browser and return to 
the application workspace.

■ Click the Import button  to save a copy of the report to your local hard 
drive. You are prompted to specify a name and path for the saved report.

■ Click the Page Up button  to move to the previous page of the report.

■ Click the Page Down button  to move to the next page of the report.

■ Click the First Page button  to jump to the first page of the report.

■ Click the Last Page button  to jump to the last page of the report.

■ Click the Print Local button  to print the report to a local printer, i.e., a 
printer that is accessible from Windows. This option downloads the report 
to your PC and uses Windows to print the report. When you select Print 
Local, a Printer Setup dialog box is displayed.

■ Click the Print Remote button  to print the report to a printer that is 
accessible from the host. This option uses the operating system on the host 
to print the report, without downloading it to your PC.

■ The Current Page/Total Pages box  shows the number of the 
currently displayed page and the total number of pages in the report.

Setting Report Browser Preferences

You can resize the browser window to fit any selected report. If the entire 
report does not fit on the screen, vertical and horizontal scroll bars enable you 
to view any part of it, as shown in Figure 3-41 on page 3-47. To customize the 

Note:  For best results with the Print Local option, you must choose an 
appropriate font size and page orientation. If the font is too large, the 
report may not page properly or may be truncated short of the right 
margin.

For reports that are up to 80 characters wide, click the Use Font check 
box on the printer setup dialog and choose Courier New, 10. Click the 
radio button for Portrait orientation.

For reports that are from 81 to 132 characters wide, click the Use Font 
check box on the printer setup dialog and choose Courier New, 8. Click 
the radio button for Landscape orientation.

In all cases, make sure that the Use character mapping check box is 
checked.
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font, background color, and text color, choose Font or Change Colors from the 
Options menu. See “Defining Your Preferences” beginning on page 3-52 for 
information on setting report browser colors and fonts.
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Getting Help
There are three categories of online Help:
■ Field Help provides an explanation of each field on each form.
■ Function Help provides a list of frequently used keyboard shortcuts.
■ Process Help provides an overview of each form.

Field Help

To access field help while working in a form, click on the field for which you 
would like help, and do one of the following:
■ Choose Field Help from the Help drop-down menu, or

■ Click the Field Help button  on the toolbar.

Function Help

Keyboard Shortcuts are keystroke combinations that can be used to perform 
functions which are normally accessed by using the mouse in Windows.

To access a list of frequently used keyboard shortcuts from any location 
within a form, choose Function Help from the Help drop-down menu. The 
Help and Function Key Information box is displayed, as shown in 
Figure 3-43. 

Note:  In addition, the About option in the Help menu enables you to 
view version and licensing information.
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Figure 3-43: Help and Function Key Information Box

Because the twelve function keys are programmed to operate differently at 
different sites and users may be confused by the default key assignments in UI 
1.0, there is an option to disable these function keys. Access the UI 
Parameters Edit (UIPR) form and set the Disable Function Keys field to Yes. 
The default is “No.”

Process Help

To access process Help from any location within a form, choose Process Help 
from the Help drop-down menu.
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Defining Your Preferences

Fonts

You can change the fonts in used in the forms, reports, resolution screens, and 
the multi-line text editor by using the Fonts dialog box.

Follow these steps to define your font preferences:

Step 1. From the Options menu, choose Font. The Font dialog box is displayed, as 
shown in Figure 3-44.

Figure 3-44: Font Dialog Box

Note:  For best results, we recommend that you configure your 
Windows display to use small fonts. With lower resolutions, such as 
800x600, some forms and resolution screens may not be displayed 
correctly using large fonts.
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Step 2. Use the drop-down lists to set the font styles and sizes individually for forms, 
reports, and resolution screens. Click OK to save the settings. The new settings 
will take effect the next time you start User Interface 1.0. 

Colors

Follow these steps to define your color preferences:

Step 1. From the Options menu, choose Change Colors. The Visual Attributes dialog 
box is displayed, as shown in Figure 3-45.

Figure 3-45: Visual Attributes Dialog Box

Note:  If you want to use a font that is available on your PC but not 
included in a drop-down list, type the font name into the edit field. If the 
font is available, the sample text below the edit field adjusts to the new 
setting. If the sample text does not change, the font is not valid.

User Interface 1.0 supports proportional fonts; however, resolution 
screens and the Report Browser require the use of fixed fonts because 
of the precise formatting of their output. For these fonts, you are 
restricted to the values supplied in the drop-down list.

Note:  The font you sent for the resolution screen is the same font that 
will be used by the multi-line text editor. For information about the 
multi-line text editor, see “Field Customization” on page 3-64. 
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Step 2. The Visual Attributes dialog box allows you to change any foreground or 
background color setting. Click Font Color or Background to the right 
of the Example Text for the color you want to change. A color palette is 
displayed, as shown in Figure 3-46.

Figure 3-46: Color Palette

Step 3. Select the color you want, and click OK to save the setting and return to the 
Visual Attributes dialog box.

Step 4. When all color selections are complete, click OK in the Visual Attributes 
dialog box to save the settings.
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Adding a Database

You can add a database in either of two ways: from the Options menu in User 
Interface 1.0, or from the Datatel User Setup program. Use this procedure if 
you are adding a database from the Options menu in User Interface 1.0. If, 
instead, you are adding a database from the Datatel User Setup program, 
refer to UI 1.0 Installation and Administration.

Step 1. From the Options menu in User Interface 1.0, select Add/Remove Databases.2

The Add/Remove Databases box is displayed.

Step 2. Identify the available database(s), listed in the Available Databases window, 
that you want this user to be able to access through User Interface 1.0. Move 
each of those databases to the Installed Databases window by selecting the 
database and then clicking the single left arrow button.

Step 3. Click OK to add the databases.

2. If the “Add/Remove Databases” option does not appear on the Options menu, it may have been disabled for 
you. Contact your system administrator.

Click this 
button to add 
a database.
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Favorites

You can use the Favorites drop-down menu to store and organize a list of 
shortcuts to frequently used forms and functions.

Adding Favorites

Perform the following steps to add a form shortcut to your Favorites list:

Step 1. In either panel, right-click the form that you want to add to your list of 
Favorites. A popup window prompts you to add the item to Favorites, as 
shown in Figure 3-47.

Figure 3-47: Menu Item Selected By Right-Clicking

Step 2. Click the Add to Favorites popup. The Enter a Mnemonic dialog box is 
displayed with the mnemonic for the selected form filled in, as shown in 
Figure 3-48.
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Figure 3-48: Enter a Mnemonic Dialog Box

Step 3. Click OK to add the form to your customized Favorites list. If you use folders 
to organize your Favorites, you can click Create in to select an existing 
folder or create a new folder for the shortcut, as shown in Figure 3-49.

Figure 3-49: Selecting a Folder for a Favorite

Note:  See “Organizing Favorites” beginning on page 3-58 for more 
information on organizing Favorites in folders.
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Step 4. The shortcut is added to your Favorites drop-down menu, as shown in 
Figure 3-50.

Figure 3-50: Favorites Drop-Down Menu

Organizing Favorites

Choose Organize Favorites from the Favorites menu to manage your list of 
shortcuts. You can create new folders, rename folders, delete unwanted 
folders, remove forms from Favorites, and move items from one folder to 
another.

Creating a New Folder. Perform the following steps to create a new folder:

Step 1. Choose Organize Favorites from the Favorites menu. The Organize Favorites 
window is displayed, as shown in Figure 3-51.

Note:  To display the Enter a Mnemonic dialog box and add a shortcut 
to Favorites without first selecting the form from the tree menu, choose 
Add to Favorites from the Favorites menu and enter the mnemonic of 
the desired form.

If you have a form open and want to add it to your Favorites list, 
choose Add Current Screen to Favorites from the Edit menu. The 
Enter a Mnemonic dialog box is displayed with the current form 
mnemonic filled in, as shown in Figure 3-48 on page 3-57.

Note:  A form cannot be renamed. However, you can create a folder 
with a descriptive name that will help you remember the form’s 
function, and then store the form shortcut in the folder. Folders can be 
used to classify forms by function, workflow, or any other property.
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Figure 3-51: Organize Favorites Window

Step 2. Click Create Folder to display the Folder Name dialog box, as shown in 
Figure 3-52.

Figure 3-52: Folder Name Dialog Box

Step 3. Enter a name for the new folder, e.g., “Demographics,” and click OK. The new 
folder appears in the Organize Favorites window, as shown in Figure 3-53.
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Figure 3-53: New Folder

Moving a Shortcut to a Folder. Perform the following steps to move a 
shortcut to a folder:

Step 1. In the Organize Favorites window, select the shortcut you want to move by 
clicking on it.

Step 2. Click Move to Folder. The Folder Selection window is displayed.

Step 3. Click on the desired folder to select it, as shown in Figure 3-54.
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Figure 3-54: Folder Selection Window

Step 4. Click OK. The shortcut is moved to the folder, as shown in Figure 3-55.
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Figure 3-55: Shortcut Moved to Folder

Renaming a Folder. Perform the following steps to rename a folder:

Step 1. In the Organize Favorites window, select the folder you want to rename by 
clicking on it. Click Rename. The folder name is now editable.

Step 2. Enter the new folder name and click Close to close the Organize Favorites 
window and save the change. In Figure 3-56, the Demographics folder is 
renamed to Demographic Information.

Note:  In addition to moving shortcuts, you can move folders into other 
folders to create a hierarchical structure.
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Figure 3-56: Renaming a Folder

Deleting a Shortcut or a Folder. Perform the following steps to delete a 
shortcut or a folder:

Step 1. In the Organize Favorites window, select the shortcut or folder you want to 
delete from Favorites by clicking on it.

Step 2. Click Delete. The shortcut or folder is removed from the Organize 
Favorites window and from the Favorites drop-down menu.

Note:  You cannot delete a folder unless it is empty. To delete a folder, 
first move or delete all of its contents.

Note:  When you delete the shortcut to a form from Favorites, the form 
is still accessible through the menus, the address bar, and the Run 
dialog box. You have only deleted the shortcut in the Favorites drop-
down menu.
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Field Customization

You can specify field behavior for a screen from within the screen itself. 
Selecting Customize Field Properties from the Tools menu of the screen you 
want to customize allows you to specify field sequence and field access for 
that screen.
■ Field Sequence - Use the First Field, Next Field Override, and Last Field 

fields to specify which field the cursor appears in when a user first accesses 
the screen, and the path followed through the screen each time a user 
presses the TAB key.

■ Field Access - Indicate which fields on the screen are required. You can 
also indicate if a field is Inquiry Only (the user can see the field, but cannot 
enter information) or No Access (the field is not visible to the user).

Keep in mind that the behavior for each field on each screen is originally 
defined by Datatel. System administrators can use the Envision Tool Kit to 
further define field behavior for an institution. You cannot take away behavior 
that is defined in the Tool Kit. For example, if a field is set in the Tool Kit as 
Required, it is always required. 

The same reasoning applies to the Field Access feature. If a field is set in the 
Tool Kit as Inquiry-Only, you cannot set that same field to be editable. You 
also cannot set field access that conflicts with the Envision Tool Kit. For 
example, if a field is set in the Tool Kit as Required, you cannot set that field 
to be inquiry-only. Conversely, if a field is set as Inquiry Only in the Tool Kit, 
you cannot set that field to be Required. See “Rules for Field Customization” 
on page 3-66 for more information about these rules.

See Figure 3-57 for an example of the Customize Field Properties 
dialog. This example shows customization of the NAE screen, but any 
Envision screen can be customized.

Note:  Before you can customize fields for a screen, your system 
administrator must first enable field customization for you and set up 
your field customization preferences.
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.

Figure 3-57: Customize Field Properties Dialog

The system administrator can also use the User Field Customization (UIFC) 
screen to specify the behavior for fields on a screen. 

Customizing Field Sequence

Customizing your field sequence can optimize the speed with which you 
move through a screen. You can specify the field you want to start in first and 
the order in which to visit each subsequent field. Each time you press the TAB 
key, you move to the next field in the specified tab sequence. When you leave 
the last field in your customized tab sequence, the screen updates.

If a next field override is not specified, the default sequence is used.

Indicates tab sequence

Technical Tip: When you access the Customize Field Properties 
dialog from a screen, you can view existing customizations for that 
screen. A series of tool tips indicates the process number of each field, 
as well as the tab sequence of each field. 

A tool tip field that is red indicates that customization is already 
applied to that field.

Customization 
already applied

Indicates process 
field number
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Customizing Field Access

Use the Field Access fields to select a security control override for the 
corresponding field. If these fields are left empty, the default User Interface 
form behavior occurs.

You can select one of the following options:
■ Required: A field on a screen is required. Users cannot finish from the 

screen without entering data into the required fields.
■ Inquiry Only: Users may only view the data; they cannot update or delete 

data.
■ No Access: Users cannot view, add, change or delete data. If a field is 

already specified as Denied Access through security classes as defined on 
the Field Security Definition (SCDF) screen, it is always Denied Access 
(Denied Access performs the same functionality as No Access).

Rules for Field Customization

The behavior for each field on each screen is originally defined by Datatel. 
System administrators can use the Envision Tool Kit to further define field 
behavior for an institution. You cannot take away behavior that is defined in 
the Tool Kit. The following rules apply to Customize Field Properties fields:

Precedence
■ Tab sequence precedence is exclusive. If one user creates a tab sequence 

and applies it to all users, a second user may still create a tab sequence for 
himself, and that tab sequence will apply only to the second user.

■ Field access precedence is inclusive. If a one user restricts field access from 
a field for all users, and a second user restricts field access from a second 
field for himself, the second user will not be able to access either field. If 
the same field has access restrictions for both all users and a specific user, 
the most restrictive access is always used.

First Field
■ A form can have only one First Field. Once a First Field is designated, you 

cannot make any other field the First Field unless you remove the existing 
designation.

Last Field
■ Fields that contain a Next Field Override cannot be designated as the form's 

last field. 
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Next Field Override
■ Fields that are specified as Last fields cannot have a Next Field Override.
■ Invalid Next Field Override fields: fields contained in the header block, 

window fields that are not window controllers (unless the current Process 
Field is a member of the same window).

Field Access
■ Fields appearing in the screen's header block can only have No Access 

restrictions applied to them.
■ When you apply a field access restriction (required, inquiry only, no access) 

to a field, you cannot apply any other field access restrictions.
■ If a field is specified as required by Envision, you cannot modify any of the 

access options.
■ If a field is specified as no access by Envision security, you cannot modify 

any of the access options.
■ If a field is specified as inquiry-only by Envision, you only have the option 

to make the field no access.

Procedure for Customizing Fields on a Screen

You may not have access to all of the options provided in this procedure. The 
options that you are presented with correspond with the level of access 
granted to you by your system administrator. This procedure describes the 
process as if you have access to all of the customization options.

Step 1. Access the screen you wish to customize.

Step 2. From the Tools menu, select Customize Field Properties to display the 
Customize Field Properties dialog.
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Step 3. Indicate if you want to modify the field properties for all users or a specific 
user:
■ Selecting Modify All Users applies the customization to all users in the 

database.
■ Selecting Modify Specific Users provides you with a dialog to enter the 

login ID of a specific user you would like to apply the customization to.
■ Do nothing if you want to modify the field properties only for yourself.

Step 4. In the Process Field drop-down list, select the number of the field you want to 
modify.

Step 5. Indicate the field sequence you want to apply to the field.
■ Select First Field if you want to indicate that the selected field is the first 

field in the tab sequence. 
■ Select Last Field if you want to indicate that the selected field is the last 

field in the tab sequence.
■ Select the next field in the tab sequence from the Next Field Override list.

Step 6. Indicate the level of field access you want to apply to the selected field.
■ Selecting Required prevents users from finishing from the screen without 

populating it.
■ Selecting Inquiry Only allows users to only view the data; they cannot 

update or delete data.
■ Selecting No Access prevents users from viewing, adding, changing or 

deleting data.

Step 7. Repeat steps 3-6 for each field you wish to customize.

Step 8. Click OK.

Note:  You do not need to click OK after customizing each field. You 
can click OK after making customizations to all of the fields on a screen 
to apply all of the customizations.

Clicking Clear Field removes customizations for the currently 
selected Process Field. All other customizations are left unchanged.

Clicking Clear All removes all customizations for the current form, 
for the user you are editing.
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Procedure for Disabling Field Sequence

After you set up custom field sequencing, you can indicate whether you want 
to activate the customizations by using the Enable/Disable Field 
Customization feature.

Step 1. Access the screen you customized.

Step 2. From the Tools menu:

Select Disable Custom Field Sequence to disable the custom field sequencing. 
A check displays next to this option when field sequencing is disabled.

Or, deselect Disable Custom Field Sequence to enable the custom field 
sequencing.

Procedure for Showing Field Sequence

You can optionally display the current field sequence of a screen. If you 
customized a field sequence, your customization displays. If you did not 
customize a field sequence, the default field sequence displays.

Step 1. Access the screen you customized.

Step 2. From the Tools menu:

Select Show Field Sequence to view the field sequence.

Or, deselect Show Field Sequence to view the screen without displaying the 
field sequence.

Note:  When you disable custom field sequencing, it is disabled only 
for the current session. When you log out of the screen and return, field 
sequencing will be enabled again.
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The Multi-Line Text Editor
User Interface 1.0 gives you the option to use either a single-line text editor or 
the multi-line text editor on the many Envision forms that let you edit text. 
This multi-line text editor lets you type text in a fixed area and automatically 
“wraps” the text when you come to the end of a line. This function lets you 
enter text without having to use a “hard carriage return” when you get to the 
end of line, similar to most desktop publishing software.

The multi-line text editor lets you select multiple lines of text or all lines of 
text and perform a “copy and paste.” See “Copy and Paste Capability” on 
page 3-75 

Single-line Text Editor vs. Multi-line Text Editor

The fundamental difference between a single-line text editor and a multi-line 
text editor is the automatic “text wrapping” capability. With a single-line text 
editor, you must manually start another line when entering text. This can be 
cumbersome and annoying when you have a large amount of text to enter. An 
example of a single-line text editor form is shown in Figure 3-58 on 
page 3-71.

The multi-line text editor screen lets you enter free-form text in a Comments 
field, Description field, and so on, and type your text without entering hard 
returns. The text wraps automatically as you type. An example of the multi-
line text editor is shown in Figure 3-59 on page 3-71. 

Note:  There are some limitations that you and your system 
administrator need to consider before implementing the multi-line text 
editor. For a discussion on these limitations, see User Interface 1.0 
Installation Procedures dated June 1, 2002 (or later). 
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Figure 3-58: Example of a Single-line Text Editor Screen 

Figure 3-59: Example of the Multi-line Text Editor Form
Guide to User Interfaces, December 31, 2003 3-71
© 2003 Datatel, Inc.



User Interface 1.0: About User Interface 1.0
When using the multi-line text editor, loading a large amount of text may take 
more time than a single-line editor. With a single-line text editor, the screen 
“loads” the text one screen, or fifteen lines, at a time. With the multi-line text 
editor, the entire block of text is loaded at once. 

Using the Multi-line Text Editor 

When you want to use the multi-line text editor to enter a block of text, detail 
on a field that has UTEDIT capability, such as a Comments field or 
Description field3. If there is existing text in the field from which you are 
detailing, and that text exceeds the text limits of the multi-line text editor, you 
will receive an alert message indicating the condition as shown in 
Figure 3-60. 

Figure 3-60: Text Exceeding Maximum Line Length Alert Message 

If you select “Y” on the Alert dialog box, the text will wrap on the multi-line 
text editor screen. You can then edit the text as needed. (If you decide not to 
keep the modified text and want the original text, select Cancel.)

If you select “N” on the Alert dialog box, the text will wrap on the multi-line 
text editor screen, but you cannot edit the text. (The editor screen displays in 
inquiry-only mode when you select “N” on the Alert dialog box.)

Figure 3-61 shows an example of text that exceeds the maximum line length. 
In this particular field, you can “scroll” through the field to read the text. 
When you detail from the field, you’ll receive the Alert dialog box.

3. Not all fields with UTEDIT capability will have the multi-line text editor feature. 
Some screens and fields are not coded to use the editor feature, but most are coded to 
take advantage of the multi-line text editor.
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Figure 3-61: Example of Text Exceeding Maximum Line Length 

If you use the multi-line text editor and want to keep text “as is,” select N from 
the Alert dialog box. Although the text will display wrapped on the text editor 
(in inquiry-only mode) as shown in Figure 3-62, the actual format will not be 
altered. 

Figure 3-62: Multi-line Text Editor in Inquiry-only Mode

Text exceeding maximum
line length
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Although the text displays in “inquiry mode” in the multi-line text editor, you 
can still use a line editor (if you have access) to modify the text. (The text is 
inquiry-only on the multi-line text editor.) To use a line editor, detail from the 
multi-line text editor to access your line editor of choice. An example is 
shown in Figure 3-63 on page 3-74. 

Figure 3-63: Example of Detailing from the Multi-line Text Editor in Inquiry-
only Mode

Detail to access
a line editor
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However, if you select “Y” on the Alert dialog box, the text will reformat in 
the text editor. You can make any changes, but if you save the information 
(that is, if you do not cancel), the text will retain the new format. An example 
of the multi-line text editor in edit mode is shown in Figure 3-64. 

Figure 3-64: Multi-line Text Editor in Edit Mode 

Copy and Paste Capability

The multi-line text editor lets you copy text from a source document and paste 
the text into the multi-line text editor. For example, you may have text from 
an e-mail or other document that you want to copy into a Comments field or a 
Description field. You can use standard copy and paste procedures between a 
source document and the multi-line text editor. 

Note:  When the text is wrapped, each line of the text is placed in its 
own line with in the record. In the example above, the one, long line of 
text is wrapped, so the one line is split into four separate lines within 
the record after reformatting. 

Note:  The multi-line text editor does not support graphics, so you 
cannot cut and paste any graphic images into the editor. However, you 
can copy text from the multi-line text editor when in inquiry-only mode.
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Loading Existing Records

If you want to load an existing record into the multi-line text editor, you can 
detail from the multi-line text editor (in edit mode or in inquiry-only mode) to 
a line editor, then perform that editor’s standard load command. An example 
is shown in Figure 3-65 on page 3-76. 

Figure 3-65: Example of Detailing from the Multi-line Text Editor to a Line 
Editor 

If the text you load exceeds the length of the maximum line length, you will 
receive the Alert message (as shown in Figure 3-60 on page 3-72). Select Y to 
reformat the loaded text. Select N to retain the loaded text’s format.

Detail to access
a line editor
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Date and Time Stamp Feature

With the single-line text editor, you can use the pound key’s symbol (#) to 
date and time stamp your text. Although the multi-line text editor does 
support the # key as your date and time stamp your text, you can use the Date/
Time/Login option from the Edit menu as shown in Figure 3-66. 

Figure 3-66: Example of the Date/Time/Login Option   

Setting the Font for the Multi-line Text Editor

The font for the multi-line text editor is the same font set for a resolution 
screen. See “Defining Your Preferences” on page 3-52 for information about 
setting fonts.

Note:  You can use the Date/Time/Login option on many fields, not just 
Comment fields and Description fields.

Technical Tip: You can also use the keyboard shortcut Alt+E S to 
access the Date/Time/Login option. (That is, press and hold the Alt 
key, then press the E key, release the keys, then press the S key.)
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